[Dojo-interest] Grid problem with one item.

Kenton Smeltzer ksmeltzer at gmail.com
Thu Feb 4 12:16:11 EST 2010


Guys,

I am having an issue with the grid, and I don't know if it is a know issue
or an issue with the way I am working with them, if my grid has only 1 item
in it, it will not display (I am only working with Firefox 3.5.3 on
openSolaris), to work around it for now  I am connecting a function to the
setStore that inspects the store for how many elements it has and adds then
removes a dummy item to the store (which is my hacky work around for now)
then the grid displayed fine but a store with only one item in it will not
display. The grid is constructed in markup and the store is late bound at a
time after the content pane with the grid is added to the page. so basically
a function is called and the store is added to the grid after the grid has
already been added to the dom.  Is this a know issue or am I doing something
wrong.

If it helps here is the markup for my grid:

 <table dojoAttachPoint ="subAffiliateGridNode"
dojoType="dojox.grid.DataGrid" query="{ id : '*' }"  autoHeight="true"
width="100%">
      <thead>
           <tr>
              <th field="id"  width="99px">Record ID:</th>
              <th field="name" width="198px" >Sub-Affiliate Name:</th>
              <th field="active" width="100px" editable="true"
cellType="dojox.grid.cells.Bool" style="text-align:center">Enabled:</th>
           </tr>
      </thead>
 </table>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.dojotoolkit.org/pipermail/dojo-interest/attachments/20100204/222b16af/attachment.htm 


More information about the Dojo-interest mailing list