[Dojo-interest] Is SDK 1.4.3 different from Release 1.4.3?

Steven Nies snies at geenius.com
Thu Jun 10 19:38:27 EDT 2010


We are having an unusual problem that I am at a loss to explain.  Our
application runs fine on the Dojo SDK 1.4.3 but not on the Toolkit Release
1.4.3.  In our environment we have two parallel Dojo directories - one
containing the SDK and the other containing the Toolkit release.  Each
directory contains the usual Dijit, Dojo, and Dojox sub-directories.  In our
application we include Dojo using the following script attribute:

[script type="text/javascript" src="/geenius/scripts/dojo/dev/dojo/dojo.js"
djConfig="parseOnLoad: true"]

We then include the Dijit components our application needs by:

dojo.require("dijit.Dialog");
dojo.require("dijit.layout.ContentPane");
dojo.require("dijit.layout.BorderContainer");
dojo.require("dijit.Menu");
dojo.require("dojo.parser");
dojo.require("dojo.data.ItemFileWriteStore");
dojo.require("dojox.grid.EnhancedGrid");
dojo.require("dojox.grid.enhanced.plugins.Menu");
dojo.require("dojox.widget.Rotator");
dojo.require("dojox.widget.rotator.Pan");

Using this configuration the application runs fine.  Our application's
"master" page displays a table of books; clicking on a book then slides a
"detail" div into view that shows the book's attributes including a table of
contents tree widget.  The user then clicks a button to slide the master
page back into view.  In essence this UI style mirrors the iPhone "swipe
left/right" user interface.

Although the above approach using the SDK works, it is slow to load due to
the various Dojo files loading one file at a time.  I've spent the past two
days trying to create a custom build to no avail - each time I run our app
Dojo crashes indicating various errors (e.g., "_18c not defined").

Today I had a thought - instead of doing a custom build I tried using the
Tookit Release libraries available from the Dojo "download" page.  I then
changed my application's javascript tag to reference the release toolkit by:

[script type="text/javascript"
src="/geenius/scripts/dojo/release/dojo/dojo.js" djConfig="parseOnLoad:
true"]

However, after doing so the application no longer works.  The app's master
page works OK, displaying the book list.  However the book's
Table-Of-Contents tree widget no longer works.  The pan left/right also no
longer works.

What surprised me is that the only difference between the two scenarios is
the working version uses the Dojo SDK; the non-working version uses the Dojo
Tooklt release of the same version.

Could someone advise me how I can fix this problem?  At this point I wasn't
sure where to post code examples.  I would be happy to post code snippets if
someone would tell me what would be useful to see.

Steve
-- 
View this message in context: http://dojo-toolkit.33424.n3.nabble.com/Is-SDK-1-4-3-different-from-Release-1-4-3-tp887212p887212.html
Sent from the Dojo Toolkit mailing list archive at Nabble.com.


More information about the Dojo-interest mailing list