[Dojo-interest] Dojo 0.9 build system, and nls files

James Burke jburke at dojotoolkit.org
Thu Aug 30 00:08:29 UTC 2007


If you can file a bug here:
http://trac.dojotoolkit.org
(use guest/guest login)

and upload a test case. Maybe a zip file with an example build
profile, and the directory structure that has the set of nls bundles
-- just including the directory structure with just the i18n bundles
should hopefully be enough to duplicate the issue. I have heard of
someone else having this problem, but they were not able to give me a
test case.

James

On 8/29/07, Rakesh Pai <rakeshpai at gmail.com> wrote:
> Ok... got some more info. The build process throws an error saying:
>
> js: "jslib/i18nUtil.js", line 221: exception from uncaught JavaScript
> throw: Cannot create flattened bundle for src file:
> ../../release/dojo/nsroot/ns/nls/SomeWidget_de-de.js
>
> Now, that file I don't have. But I haven't requireLocalization for
> that folder in my code at all.
>
> dojo.requireLocalization("nsroot", "common"); That's all I have.
>
> Again, this works fine before it's built, but during/after building, it breaks.
>
> Any help will be hugely appreciated.
>
>
> On 8/29/07, Rakesh Pai <rakeshpai at gmail.com> wrote:
> > I'm sorry, I forgot to include the error before this:
> >
> > failed loading  scripts/dojo/../nsroot/ns/SomeWidget.js  with error:
> > Error: Bundle not found: common in nsroot, locale=en-us
> >
> > Now, I have created a common.js file in the nls folder in the nsroot
> > folder. However, there's no en-us file there. That should work,
> > shouldn't it?
> >
> > On 8/29/07, Rakesh Pai <rakeshpai at gmail.com> wrote:
> > > Hey,
> > >
> > > I'm getting the following error in Firebug when running my build:
> > >
> > > [Exception... "'Error: Could not load 'nsroot.ns.SomeWidget'; last
> > > tried '../nsroot/ns/SomeWidget.js'' when calling method:
> > > [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001c
> > > (NS_ERROR_XPC_JS_THREW_JS_OBJECT)" location: "<unknown>" data: no]
> > >
> > > I haven't included any nls files in my profile definition.
> > >
> > > What's weird is that Firebug doesn't show any attempt to reach any
> > > file in the nls folder.
> > >
> > > Any idea what might be going wrong?
> > >
> > > (Everything seems to be going fine in my local setup. I only get this
> > > error when building.)
> > >
> > > --
> > > Rakesh Pai
> > > Mumbai, India.
> > > rakesh.pai at gmail.com
> > > http://piecesofrakesh.blogspot.com/
> > >
> >
> >
> > --
> > Rakesh Pai
> > Mumbai, India.
> > rakesh.pai at gmail.com
> > http://piecesofrakesh.blogspot.com/
> >
>
>
> --
> Rakesh Pai
> Mumbai, India.
> rakesh.pai at gmail.com
> http://piecesofrakesh.blogspot.com/
> _______________________________________________
> FAQ: http://dojotoolkit.org/support/faq
> Book: http://dojotoolkit.org/docs/book
> Forums: http://dojotoolkit.org/forum
> Dojo-interest at dojotoolkit.org
> http://dojotoolkit.org/mailman/listinfo/dojo-interest
>


More information about the Dojo-interest mailing list