[dojo-contributors] dojo.lang.inherits

Tom Trenka ttrenka at gmail.com
Fri Apr 7 12:36:49 EDT 2006


Works for me.

On 4/7/06, Alex Russell <alex at dojotoolkit.org> wrote:
>
> +1
>
> On Friday 07 April 2006 7:40 am, Sandro Magi wrote:
> > Bill Keese wrote:
> > > I feel like my meaning didn't get across.
> > >
> > > It seems like everyone is discussing whether or not we should
> > > rename dojo.inherit to dojo.delegate.  (Personally I don't care
> > > either way.)
> > >
> > > But, my original suggestion was to write a function (what I called
> > > defineClass()) that combines the features of dojo.inherit and
> > > dojo.extends, plus defines a constructor. Isn't it weird to call
> > > that delegate?  Delegation is only 1/3 of what that function does.
> >
> > In an effort to avoid overloaded words, how about:
> >
> > dojo.declare(...)
>
> --
> Alex Russell
> alex at jot.com
> alex at dojotoolkit.org BE03 E88D EABB 2116 CC49 8259 CF78 E242 59C3 9723
>
>
> _______________________________________________
> dojo-contributors mailing list
> dojo-contributors at dojotoolkit.org
> http://dojotoolkit.org/mailman/listinfo/dojo-contributors
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.dojotoolkit.org/pipermail/dojo-contributors/attachments/20060407/a2e04736/attachment.htm 


More information about the dojo-contributors mailing list