[dojo-contributors] dojo.lang.inherits

Sandro Magi smagi at naasking.homeip.net
Fri Apr 7 10:40:29 EDT 2006

Bill Keese wrote:
> I feel like my meaning didn't get across.
> It seems like everyone is discussing whether or not we should rename
> dojo.inherit to dojo.delegate.  (Personally I don't care either way.)
> But, my original suggestion was to write a function (what I called
> defineClass()) that combines the features of dojo.inherit and
> dojo.extends, plus defines a constructor. Isn't it weird to call that
> delegate?  Delegation is only 1/3 of what that function does.

In an effort to avoid overloaded words, how about:



> Maybe I misunderstood something?
> Bill
> Bill Keese wrote:
>> What does delegate mean?  I'm thinking delegate means something
>> similar to "inherit", which isn't appropriate in this case because
>> it's not just inheritance, it's the whole class definition (the
>> combination of constructor, dojo.inherits, and dojo.extends)
>> Sandro Magi wrote:
>>> +1 to delegate.
>>> It's closer to the proper concept.
>>> Sandro
>>> Alex Russell wrote:
>>>> To address Jesse's point, how about a name like:
>>>>     dojo.delegate(subclass, superclass, { ... });
>>>> ?

More information about the dojo-contributors mailing list