[dojo-contributors] dojo.lang.inherits

Bill Keese bill at dojotoolkit.org
Thu Apr 6 22:58:47 EDT 2006


I feel like my meaning didn't get across.

It seems like everyone is discussing whether or not we should rename 
dojo.inherit to dojo.delegate.  (Personally I don't care either way.)

But, my original suggestion was to write a function (what I called 
defineClass()) that combines the features of dojo.inherit and 
dojo.extends, plus defines a constructor. Isn't it weird to call that 
delegate?  Delegation is only 1/3 of what that function does.

Maybe I misunderstood something?

Bill

Bill Keese wrote:
> What does delegate mean?  I'm thinking delegate means something similar 
> to "inherit", which isn't appropriate in this case because it's not just 
> inheritance, it's the whole class definition (the combination of 
> constructor, dojo.inherits, and dojo.extends)
> 
> Sandro Magi wrote:
>> +1 to delegate.
>>
>> It's closer to the proper concept.
>>
>> Sandro
>>
>> Alex Russell wrote:
>>> To address Jesse's point, how about a name like:
>>>
>>>     dojo.delegate(subclass, superclass, { ... });
>>>
>>> ?
>>>
>>> On Wednesday 05 April 2006 5:33 pm, Scott J. Miles wrote:
>>>> dojo.defineClass(subclass, superclass, { constructor: ..., param1:
>>>> ..., func1: ... });
>>>>
>>>> +1
>>>>
>> _______________________________________________
>> dojo-contributors mailing list
>> dojo-contributors at dojotoolkit.org
>> http://dojotoolkit.org/mailman/listinfo/dojo-contributors
> 



More information about the dojo-contributors mailing list