[dojo-contributors] container widget name changes (pane vs. container vs. nothing)

Bill Keese bill at dojotoolkit.org
Wed Apr 5 00:30:30 EDT 2006


OK, I changed the names.  The change consists of module name changes
(ex: dojo.widget.SplitPane became dojo.widget.SplitContainer), and also
CSS class name changes (ex: .dojoTabPane now refers to an individual tab
whereas it used to refer to a collection of tabs).

Alex thought we should provide backwards compatibility stubs for the old
names, so existing dojo customers have time to migrate their apps.  This
is the normal dojo procedure (deprecating the old names).

The counter-argument is that it will confuse people, since they will
assume that a LayoutPane is a child of a LayoutContainer, and SplitPane
is a child of a SplitContainer, etc.; that's why we changed the names in
the first place.  Also, the CSS changes probably aren't stubbable, since
there are naming conflicts.

Comments/Opinions?

Bill

Bill Keese wrote:
> OK, that's 5 votes for "Container" and 1 vote against, so I will change
> the names to:
> 
>>>> SplitContainer
>>>> TabContainer
>>>> LayoutContainer
>>>> WizardContainer
> 
> Alex Russell wrote:
>> Seconded.
>>
>> On Thursday 30 March 2006 7:05 am, Tom Trenka wrote:
>>> It sounds good to me.
>>>
>>> trt
>>>
>>> On 3/30/06, Bill Keese <bill at dojotoolkit.org> wrote:
>>>> There's a set of widgets in dojo that operate on a list of child
>>>> widgets:
>>>>
>>>> SplitPane
>>>> TabPane
>>>> LayoutPane
>>>> AccordionContainer
>>>> Wizard
>>>>
>>>> The word "pane" is confusing because, for example, TabPane sounds
>>>> like a single tab, rather than the set of tabs.  Also, "WizardPane"
>>>> is in fact a single screen within the wizard.  So planning to call
>>>> everything "Container":
>>>>
>>>> SplitContainer
>>>> TabContainer
>>>> LayoutContainer
>>>> AccordionContainer
>>>> WizardContainer
>>>>
>>>> Does that sound OK?  Alternately it could be "SplitContainer,
>>>> TabSet, Accordion, and Wizard", which might be better, but has the
>>>> downside that the naming is inconsistent.  (Dustin thought naming
>>>> consistency was important.)
>>>>
>>>> Note that this doesn't affect things like ContentPane and
>>>> FloatingPane, because they are essentially a single thing, not a
>>>> list of things.
>>>>
>>>> Comments?
>>>>
>>>> Bill
>>>> _______________________________________________
>>>> dojo-contributors mailing list
>>>> dojo-contributors at dojotoolkit.org
>>>> http://dojotoolkit.org/mailman/listinfo/dojo-contributors
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> dojo-contributors mailing list
>> dojo-contributors at dojotoolkit.org
>> http://dojotoolkit.org/mailman/listinfo/dojo-contributors
> 



More information about the dojo-contributors mailing list