[Dojo-checkins] [dojo] #8380: Enhance dojo.place()

dojo trac at dojotoolkit.org
Sun Jan 18 19:38:09 UTC 2009


#8380: Enhance dojo.place()
-------------------------+--------------------------------------------------
 Reporter:  elazutkin    |        Owner:  dante   
     Type:  enhancement  |       Status:  assigned
 Priority:  high         |    Milestone:  1.3     
Component:  HTML         |      Version:  1.2.3   
 Severity:  normal       |   Resolution:          
 Keywords:               |  
-------------------------+--------------------------------------------------

Comment(by mikewse):

 Replying to [comment:8 mikewse]:
 > dojo.place() with position="only" is not so intuitive I think. I'll try
 to think of alternatives.

 As promised I've done a little thinking about the placement names. I had a
 look at HTML5 and realized that IE's outerHTML is actually making it into
 the standard.

 With the current naming scheme the following will be equivalent (I
 guess?):
 {{{
 dojo.place("<div>...</div>", parentNode, "only");
 dojo.attr(parentNode, "innerHTML", "<div>...</div>");
 }}}
 and so will the following:
 {{{
 dojo.place("<div>...</div>", parentNode, "replace");
 dojo.attr(parentNode, "outerHTML", "<div>...</div>");
 }}}

 Looking at this, my best suggestion for alternatives to only/replace is
 something that involves "inner" and "outer". The most descriptive would be
 replaceInner/replaceOuter but that is too long. If you consider it
 interesting we can probably find something suitable.

-- 
Ticket URL: <http://trac.dojotoolkit.org/ticket/8380#comment:16>
dojo <http://dojotoolkit.org/>
The Dojo UI Toolkit


More information about the Dojo-checkins mailing list